Are there any specific system requirements I need to know about before redeeming my Photo Calendar?

You will need a recent version of Adobe Flash Player.  You can check your current version and update it for free here: http://get.adobe.com/flashplayer/

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk